Login | Register
My pages Projects Community openCollabNet

Discussions > tsWebEditor > Re: tsWebEditor Debug Problem

Project highlights: home | downloads | news | features | screenhots | support

Discussion topic

Back to topic list

Re: tsWebEditor Debug Problem

Author yacaph
Full name Joseph McLaughlin
Date 2008-05-04 06:38:23 PDT
Message >>>Turn on the log.
>>> - in the editor
>>> - or php.ini: xdebug.remote_log
>>> http://xdebug.org/do​cs/remote#remote_log​
>>I tried both turning the log on via the debug parameters
>>page and by directing directing it to a file via
>>xdebug.remot​e_log=C:\xdebug.log​ in my php.ini
>are you sure it was the right php.ini, use phpinfo() to
>check it.
>have you seen
>http://tswebeditor.a​tspace.org/doc/edito​r_dbg.html ? (not
>very up-to-date, but helps)


All of my settings appeared to be correct according to the
info contained in Chapter 10, but when I ran the debugger
from the browser I got a "no input file specified" error.

After some online research I changed my doc_root setting in
php.ini from "doc_root = d:\inetpub\wwwroot to doc_root =
d:\, re-booted then changed it back to doc_root =
d:\inetpub\wwwroot and re-booted again and re-ran
XDEBUG_SESSION_START​=tswebeditor from the browser. This
time tsWebEditor worked and a log file was created, but I
was unable to stop the debug session after I stepped
through the loop. I closed the editor then re-opened
xdebug_test.php in tsWebEditor and was able to step through
it, but again was not able to stop the debug session within
the editor as all buttons were disabled. After closing and
re-starting the editor I found myself back to the error
that started this thread:

Exception from Debugger
Can not get property(when the requested property to get did
not exist, thei is NOT used for and existing but
property , which just gets the type "uninitialised" (See

can not get property

I re-booted again, but still get the error. I'm including
the log entries for your review. They don't tell me very
much - I hope that they mean something to you.



Log opened at 2008-05-04 13:09:07
-> <init xmlns="urn:debugger_​protocol_v1"
language="PHP" protocol_version="1.0" appid="2120"
idekey="administrato​r"><engine version="2.0.3"><![CDATA
[Xdebug]]></en​gine><author​><![CDATA[Derick​ Rethans]]
></url><​copyright><![C​DATA[Copyright (c) 2002-2008 by
Derick Rethans]]></co​pyright></init​>

<- feature_set -i 1 -n multiple_sessions -v 0
-> <response xmlns="urn:debugger_​protocol_v1"
command="feature_set" transaction_id="1"
feature="multiple_sessions" success="1"></​response>

<- status -i 2
-> <response xmlns="urn:debugger_​protocol_v1"
command="status" transaction_id="2" status="starting"

<- breakpoint_set -i 3 -t line -s enabled -f file:///D:%
5CInetpub%5Cwwwroot%​5Cxdebug%5Ftest.php -n 5
-> <response xmlns="urn:debugger_​protocol_v1"
command="breakpoint_set" transaction_id="3" state="enabled"

<- breakpoint_set -i 4 -t line -s enabled -f file:///D:%
5CInetpub%5Cwwwroot%​5Cxdebug%5Ftest.php -n 3
-> <response xmlns="urn:debugger_​protocol_v1"
command="breakpoint_set" transaction_id="4" state="enabled"

<- run -i 5
-> <response xmlns="urn:debugger_​protocol_v1"
xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="run"
transaction_id="5" status="break"

<- stack_get -i 6
-> <response xmlns="urn:debugger_​protocol_v1"
command="stack_get" transaction_id="6"><stack
where="{main}" level="0" type="file"

<- property_get -i 7 -n i
-> <response xmlns="urn:debugger_​protocol_v1"
command="property_get" transaction_id="7" status="break"
reason="ok"><error code="300"><me​ssage><![CDATA​[can not get

<- stop -i 8
-> <response xmlns="urn:debugger_​protocol_v1"
xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stop"
transaction_id="8" status="stopped" reason="ok"></​response>

-> <response xmlns="urn:debugger_​protocol_v1"
xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stop"
transaction_id="8" status="stopping" reason="ok"></​response>

Log closed at 2008-05-04 13:09:12

« Previous message in topic | 5 of 7 | Next message in topic »


Show all messages in topic

tsWebEditor Debug Problem yacaph Joseph McLaughlin 2008-04-25 08:40:54 PDT
     Re: tsWebEditor Debug Problem thaj Thaler 2008-04-26 07:20:03 PDT
         Re: tsWebEditor Debug Problem yacaph Joseph McLaughlin 2008-05-02 10:28:06 PDT
             Re: tsWebEditor Debug Problem thaj Thaler 2008-05-03 11:08:46 PDT
                 Re: tsWebEditor Debug Problem yacaph Joseph McLaughlin 2008-05-04 06:38:23 PDT
                     Re: tsWebEditor Debug Problem thaj Thaler 2008-05-04 09:20:47 PDT
                         Re: tsWebEditor Debug Problem yacaph Joseph McLaughlin 2008-05-05 13:02:44 PDT
Messages per page: